Implantation bleeding?! - Mothering Forums

Forum Jump: 
 
Thread Tools
Old 07-19-2012, 03:00 PM - Thread Starter
 
amandaperry1's Avatar
 
Join Date: Jul 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Im new to this so hopefully Im posting in the right place...

 

Im not due for my period until next week. However two days ago I started what I thought might be my period but all I have had is some cramping with brown blood and its not heavy at all. so light I dont even need a liner or anything. My periods are usually pretty normal, I have never had one like this. I took a test today it said negative (I believe). I've had two children before without any of this but my last pregnancy ended in an emergency c-section... What do you guys think? Really need help here, I have been on the pill and really dont want to hurt the baby by continuing if I am..Thank you in advance.

amandaperry1 is offline  
Sponsored Links
Advertisement
 
Old 07-20-2012, 06:56 PM
 
QueenOfTheMeadow's Avatar
 
Join Date: Mar 2005
Location: with the wildlife
Posts: 17,836
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)

Hi amanda.  Welcome to MDC.  Well, I'm not sure this will help, but I was pregnant on the pill, and what you are describing is what I went through. But I also had some odd periods here and there over the few years I was on the pill without being pregnant!  Getting pregnant on the pill, if you are taking it properly is really rare.   If you are really worried,  you could contact your doctor and see if they can do a blood test.  I wouldn't suggest going off the pill until you know for sure. 


 
QueenOfTheMeadow is offline  
 

Tags
Trying To Conceive
User Tag List

Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off