Cycle seems whacked. - Mothering Forums

Forum Jump: 
 
Thread Tools
#1 of 4 Old 03-15-2014, 05:34 AM - Thread Starter
 
astromum's Avatar
 
Join Date: Aug 2012
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi everyone. sorry to be a pain but.I'm having some stuff going on with my cycle that I'm confused.about and was wondering if anyone else had experienced such a thing.

normally my periods are regular with medium flow and last about five days. in January I got two periods and finished the second one around feb 5. march around the 7th I get very light spotting for a week, didn't even Ned a pantiliners, just got a couple dots on my underwear 2 or 3 days but mostly just would notice slight pink tinge only sometimes after using the bathroom. it was barely there.

so I haven't had this for a couple days now, and this morning the second time I went pee when I wiped there was discharge along with the pink. it looked like mucus or what you might have when you're ovulating, but pink.

I'm just wondering what's going on. took a preg test and came out negative. wondering if maybe it's my progesterone levels causing it?

any experience you've had would be so helpful to hear. thank you.
astromum is offline  
Sponsored Links
Advertisement
 
#2 of 4 Old 03-15-2014, 05:35 AM - Thread Starter
 
astromum's Avatar
 
Join Date: Aug 2012
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sorry for the typos, posted from my phone!
astromum is offline  
#3 of 4 Old 03-16-2014, 12:39 PM
 
badwolf092087's Avatar
 
Join Date: Nov 2013
Location: Stamford, CT
Posts: 943
Mentioned: 45 Post(s)
Tagged: 0 Thread(s)
Quoted: 96 Post(s)
I'd honestly say talk to your doctor. They would know best. The only things I could think of would be pregnancy or stress affecting your cycle.

Sarah & DH Alan 
 
Our angel in heaven, DS Connor 10/2/09 to 10/5/09  
2 pups, 11 cats  and always rescuing more!  RIP Momma Furby </3
Baby #2, a GIRL!, due Nov 29th, 2014  

badwolf092087 is online now  
#4 of 4 Old 03-16-2014, 04:43 PM - Thread Starter
 
astromum's Avatar
 
Join Date: Aug 2012
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mystery solved, took another test and it came out positive. thanks for your reply smile.gif
badwolf092087 likes this.
astromum is offline  
Reply

Tags
Trying To Conceive

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off