anovulatory cycles? - Mothering Forums
Forum Jump: 
 
Thread Tools
#1 of 4 Old 09-21-2005, 02:21 PM - Thread Starter
 
homemademomma's Avatar
 
Join Date: Apr 2004
Location: ct
Posts: 2,974
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
okay, so ive been ttc for 4 months now, ever since i got my PPAF back. every month my cycle has gotten 1-2 days longer. last cycle was 32 3/4 days long. i start getting some EWCF around day 17 ish, and then i get it off and on until day 25 or so. i have been temping, but my temps are ALL over the place bc ds nurses so frequently that i rarely get a sold 2 hours sleep before temping, and even if i do i almost always roll over or move before i get my temp to take care of ds.

anyway, the fact that i get EWCF for so long makes me think that maybe my body is trying to O, but just cant quite get there bc ds still nurses so much. what do you think? me and dh had sex for 2 1/2 weeks, every 24-48 hours, trying to cover our bases, but here i am on CD 31 with a neg test. i know its still possible to i will get a positive, but i really think im not ovulating. any insights or tips to help my body get over the hormone hill and lay an egg?

Mom to two perfect kids earth.gif  surrogate to two sweetpotatos heartbeat.gifheartbeat.gif born 4.21.11  

I love someone with ataxia telangiectasia http://www.atcp.org

homemademomma is offline  
#2 of 4 Old 09-23-2005, 10:20 AM - Thread Starter
 
homemademomma's Avatar
 
Join Date: Apr 2004
Location: ct
Posts: 2,974
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Mom to two perfect kids earth.gif  surrogate to two sweetpotatos heartbeat.gifheartbeat.gif born 4.21.11  

I love someone with ataxia telangiectasia http://www.atcp.org

homemademomma is offline  
#3 of 4 Old 09-23-2005, 02:45 PM
 
MoonStarFalling's Avatar
 
Join Date: Nov 2004
Location: IL
Posts: 2,765
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I'm having the same problem. I haven't O'd in 5 months, and even when I was Oing I would be late in my cycle. I get lots of hormone surges. It's like I just can't get up enough hormones to O. For that reason this cycle I'm on vitex and red raspberry leaf tea (every day), wild yam and soy (CD 3-7).

Homeschooling mom of two plus baby R born December 16 love.gif
MoonStarFalling is offline  
#4 of 4 Old 09-23-2005, 03:34 PM
 
BundleFishMama's Avatar
 
Join Date: Jun 2005
Location: Philadelphia suburbs
Posts: 1,515
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had the exact same problem, 4 months of long, anovulatory cycles with sporadic periods of EWCM but no O and then random bleeding....Vitex worked really well and really quickly for me, I O'd about 4 weeks after I started taking it, and now I'm on my second nice and normal cycle! Of course, time also helps as your kids gradually space out their nursings more, you never know. Good luck!

Kerriintactlact.gif blessed single mama to Teresa 8/2/02blahblah.gif, Madeleine 5/28/04dust.gif, Andrew 6/25/06jammin.gif, and Isabelle ribboncesarean.gif11/27/08energy.gif

BundleFishMama is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mothering Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off