Don't think this is the month either - Mothering Forums

Forum Jump: 
 
Thread Tools
Old 03-22-2008, 03:57 PM - Thread Starter
 
CalaRei's Avatar
 
Join Date: Mar 2008
Location: Seattle
Posts: 878
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I know it's early yet - we have only been trying for 3 months, but I'm worried that something is wrong.

The past two months, as the day of expected O approached, my CM acted appropriately - more of it, and progressively stretchier. And then I started spotting. In January I had seen my Gyn because I had been having a full period every other week. I had some blood work and an u/s and the doc said everything was ok and that I still probably had depo in my system from April 2007!!! (Of course in between there, I had been on nuvaring, too!)

I'm trying to be patient and at least wait until a year after I'd had the last depo shot, but I'm becoming very worried.

If I suspect a problem, should I still wait the whole year before I call about fertility issues?

Has anyone else had problems after depo? The warnings about this are there, but very very small. Of course.

Sorry this is rambling... I just wanted a bit of advice and maybe some commiseration.

Mama to twin boys, Oct-'09 and baby girl, Apri-'12!

CalaRei is offline  
Sponsored Links
Advertisement
 
Old 03-22-2008, 04:34 PM
 
juliav's Avatar
 
Join Date: Nov 2007
Location: Ottawa
Posts: 906
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I haven't used Depo, but it took me more than a year to get back to what seems like normal for me after coming off the pill. And I think Depo probably stays in your system longer?? I had irregular bleeding, missed periods some months and spotted for what seemed like ages. I know it's really frustrating but I'd be more inclined to give your body a bit more time to straighten itself out. Hormones do crazy things to us.
juliav is offline  
 
User Tag List

Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off