If you've ever had a depo shot ... - Page 2 - Mothering Forums

Forum Jump: 
Reply
 
Thread Tools
#31 of 34 Old 08-14-2009, 01:05 AM
 
SeekingSerenity's Avatar
 
Join Date: Aug 2006
Location: Hiding out in the mountains
Posts: 1,701
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by UberMama View Post
Depo realllllly messed my body up.
I thought I was the only one who'd gone through that. My XH thought it was "all in my head" because I'd only gotten one shot, even though he was right there through the four months of bleeding followed by three more of spotting.

Quote:
Originally Posted by teale View Post
... because it was literally wreaking havoc on my emotions.
I was a complete and utter wreck. And that's saying something because this was during a time in my life when I wasn't precisely at my best to begin with. It took eons to get a "regular" cycle back, and then I got pg and had a m/c when everything started to seem halfway normal again.

Quote:
Originally Posted by *MamaJen* View Post
So have any of you actually managed to have an orgasm while on Depo? Because I absolutely could not.
Well, no, but I am not sure that was the depo... since I think I can remember only a handful of times I had one at ALL with my ex, in the almost-8 years of marriage... heh.

)O(   Far-away Mama to: Pooka (16)...Alex (14)...Mickie-Lamb (13)...Solo Mama to: Punkin' Seed (8)...Tootsie Pop (6)...Lil' Man (3) and a yikes2.gif due February 2012

~~~~ribbonpurple.gifDV Survivor/Fibroribbonpurple.gif~~~~ 

4***8***12***16***20***24***28***32**heartbeat.gif36***40

SeekingSerenity is offline  
Sponsored Links
Advertisement
 
#32 of 34 Old 08-31-2009, 10:13 PM
 
lactavia's Avatar
 
Join Date: Aug 2005
Location: Providence Area
Posts: 272
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I was on it for about 3 or 4 years. And also had no side effects at all. I lost weight while on it, had no periods, and it didn't have any effect on my libido at all.

However - getting off it was horrendous. For about 10 months I had no symptoms and no period. Then when my period finally came, I was a wreck with major PMS. It took about three cycles and my periods and PMS were regular again. We were pregnant about 5 regular cycles in.

I did not know of any of the nasty side effects until well after I was off the Depo. I was shocked and mortified when I read them. I'm glad I got off it.

Quote:
Originally Posted by justKate View Post
I hate to be the one, but I have to say I did like it. Please don't flame me. I know it doesn't work well for a lot of people, but I was on it for 5 years (which is not recommended); did not have periods, no cramping, no weight gain, no side effects whatsoever. I got my last shot in Dec. '07 and got pregnant in May '08. THIS MAY NOT BE YOUR EXPERIENCE. I don't, however, plan to get another shot any time soon as I am nearing 30 and want more children in the next couple years.

So that's my 2 cents.
lactavia is offline  
#33 of 34 Old 09-01-2009, 09:21 AM
 
DanaMarie's Avatar
 
Join Date: Aug 2005
Location: New Jersey
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had my first depo shot 6 weeks postpartum while tandem nursing 1year old n newborn i was 21. I stayed on depo 18 mnths. I think i agree with previous poster that age n cycles pre-depo may hav smethg to do with how u bounce back. I'll also add to that my nursing may hav affected how depo worked for me. I never had any breakthrough bleeding and no period the whole time which of course was lovely for DH. I didnt feel my libido changed at all.

On the downside though it did make me moody and although my hair was thinning before depo i hav had serious hair loss since then and iight contribute some of that to depo side effects.


My period came back abt 6-7 mnths aftr last shot should hav worn off or 9-10mnths after last shot.

Best of luck to everyone trying to heal.

 hijab.gif married to DH  mom to 3 boys, 1 girl
DanaMarie is offline  
#34 of 34 Old 09-01-2009, 03:50 PM
 
brittneyscott's Avatar
 
Join Date: Mar 2006
Location: Way down south
Posts: 1,136
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I've been on depo twice. The first time was before I had kids and I had one shot. It took about 6 mos from the time I was suppose to get the second shot before I had a cycle. Once I did have a cycle though it was normal and I got pregnant 2 or 3 months later. After dd I had 3 depo shots. They gave me provera about 2 mos after I was suppose to get the next shot to try to start my cycles back. You should take provera for one week then start a cycle but it didn't work for me. About a month after taking the provera I started bleeding and bled for 21 days straight before they started me on bcp. I took one month's cycle of the pills and got pregnant with ds right after stopping them. I wouldn't ever take depo again after the way it did my body the last time!
brittneyscott is offline  
Reply

Quick Reply
Message:
Drag and Drop File Upload
Drag files here to attach!
Upload Progress: 0
Options

Register Now

In order to be able to post messages on the Mothering Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off