Mirena IUD and Chronic Urinary Tract Infections - Mothering Forums

Forum Jump: 
 
Thread Tools
#1 of 3 Old 01-22-2012, 12:53 PM - Thread Starter
 
BentleysMama's Avatar
 
Join Date: Jan 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I have had my Mirena IUD since March of 2011 and ever since I had it placed when my son was 6 weeks old at my postpartum check up, I have hhad and pretty much kept a UTI... Does anyone know if this is normal or common? I checked the Mirena website and it says nothing about UTI's anywhere there.... I need some help! 

I have had good results with my IUD and until recently I have been very pleased with it, but If this doesn't stop soon I'm having it removed and going back to NuvaRing or the patch!

BentleysMama is offline  
Sponsored Links
Advertisement
 
#2 of 3 Old 02-08-2012, 10:48 AM
 
NoahandKinley's Avatar
 
Join Date: Feb 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I have also been having the same problems. I got my IUD about the same time you did and have had a UTI ever since. Antibiotics are not working. I am also debating taking it out.

NoahandKinley is offline  
#3 of 3 Old 02-08-2012, 11:12 AM
 
NoahandKinley's Avatar
 
Join Date: Feb 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I have also been having the same problems. I got my IUD about the same time you did and have had a UTI ever since. Antibiotics are not working. I am also debating taking it out.

NoahandKinley is offline  
Reply

Tags
Family Planning

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off