copper iud since july 2012 - Mothering Forums

Forum Jump: 
 
Thread Tools
Old 04-07-2013, 01:25 PM - Thread Starter
 
mommyofarm's Avatar
 
Join Date: Apr 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

hello i got the iud abouut 8 months ago didnt have any problems only heavy periods no spotting no missed periods and always on time until now its been about a month and ive been spotting its like reddish  brownish Nd sometimes pinkish and everytime i use tbe restroom i  clean myself and theres pinkish but not in my pee... i was suppose to get my perriod  but nothing yet i went to the dr a week ago to make sure the iud was in place and it is and ive been cramping like 3 weeks ago i felt like i had labor pains but they went away after 2 days has anybody experience something like this ... what  could it be...???

mommyofarm is offline  
Sponsored Links
Advertisement
 
Old 04-09-2013, 07:58 AM
 
mamazee's Avatar
 
Join Date: Jan 2003
Location: US midwest
Posts: 7,246
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
It is possible, although not common, to get pregnant while using an IUD. Have you taken a pregnancy test?

I would probably go back to the doctor and say you still haven't had a real period and you've been spotting for three weeks, otherwise.
mamazee is offline  
Old 04-11-2013, 02:05 PM - Thread Starter
 
mommyofarm's Avatar
 
Join Date: Apr 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I havent took a pregnancy test since i dont fell pregnant at all i havr 3 kids and i dont have any pregnancy symptoms... But ill go ahead and do one to make sure is not that ...

Thankz ill have to make another appt ASAP because so far im still spotting and no period yet..! ;(
mommyofarm is offline  
 

Tags
Family Planning
User Tag List

Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off