UM, FAM help? Please! - Mothering Forums

Forum Jump: 
 
Thread Tools
#1 of 2 Old 05-08-2004, 06:42 PM - Thread Starter
 
wendy1221's Avatar
 
Join Date: Feb 2004
Location: NC
Posts: 5,301
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I think we had a big boo boo last night. Jake is almost 8 mos old now and I got my first period at 6 mos (which really sucks. I didn't get it for 18 mos w/ my first). I had just bought the book Taking Charge of Your Fertility about 2 days before I got it. I knew something was going on b/c of the mucous thing, which I knew enough about to prevent getting pregnant for 3 years (but not enough to prevent getting pg w/ Jake while on vacation and not watching the calendar/paying attention to my mucous. LOL!) Haven't had one yet since then.

So I bought an Ovuscope from Target on Tues after a friend suggested it. I had had 2 weeks of eggwhite by that point and was getting pretty fed up. She said it might be nice to have a 4th sign (3rd for me since I haven't been checking my cervix, though I keep thinking I should start). It showed ferning Tues and Wed (I do it in the AM. Lick the glass and let it dry while I shower). My temp also went up on Wed, so yeasterday morning was my 3rd day of temps above the baseline, plus the ovuscope showed no ferning at all, so I told dh it was safe and we had some fun (4 yo slept in his own bed on his own for a change! No asking involved! Hooray! LOL!). Now this morning, my temp was down again and I used the ovuscope and it was complete ferning. What do you think?

God, I hope I'm not pregnant!!! Dh is a grad student and I'm currently temping part-time. I just don't know how we'll handle it! I might even consider abortion, though I hate even saying that. I mean, Jake's not even a year old. I don't want my milk to dry up on him! Arg!!! I mean, I've slipped twice in all the times I've had sex in my life and I've had a baby to show for it both times. I have reason to be paranoid. Anyone have any explanation for the 3 days of high temps and apparent ovulation, then the low temp and ferning w/ the ovuscope? Thanks so much!

Wendy
wendy1221 is offline  
Sponsored Links
Advertisement
 
#2 of 2 Old 05-10-2004, 03:09 PM - Thread Starter
 
wendy1221's Avatar
 
Join Date: Feb 2004
Location: NC
Posts: 5,301
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Never mind. Now I'm showing infertile signs and I got my period again this morning! Cramps and all. Arg!!! At least I'm sure this one HAS to be annovulatory since I'm 100% sure I didn't ovulate 2 weeks ago! This really sucks! Why couldn't I just not get a period for 18 months like last time I was nursing? LOL!

Wendy
wendy1221 is offline  
Reply

Quick Reply
Message:
Drag and Drop File Upload
Drag files here to attach!
Upload Progress: 0
Options

Register Now

In order to be able to post messages on the Mothering Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off