Blood in urine? - Mothering Forums

Forum Jump: 
 
Thread Tools
Old 12-06-2011, 06:32 PM - Thread Starter
 
bluedaisy's Avatar
 
Join Date: Sep 2008
Posts: 637
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)

My midwife has my pee in a cup each time and has a stick that tests for various things - for the past two months, it has showed that there is blood in my urine but nothing else.  The first time DH and I had had  sex that morning redface.gif so she thought it might be a little bleeding from the sex.  Since there were no leukocytes present and I had no signs of a UTI she didn't think it was that.

 

But every visit since then there has been blood (about 5 times) and a few of those times we hadn't had sex in at least 24 hours.  She sent my urine to be tested over a month ago and it came back as inconclusive - i think the numbers were borderline or something.

 

So for the last two weeks I've been taking tons of cranberry but today there was still blood.  She sent another sample off today but she's not sure what is going on.

 

Any ideas what this could be?  I've had UTIs before and even though I pee all the time it's different than UTI - most of the time it's a significant amount and there is no burning or blood that I can see.

 

I'm 32 weeks and a little nervous since I've read that untreated UTIs can cause premature labor.


Loving wife to DH and buddamomimg1.pngmama to DD (11/08) and DS (2/12)

bluedaisy is offline  
Sponsored Links
Advertisement
 
Old 12-09-2011, 08:31 AM
 
parsley's Avatar
 
Join Date: May 2011
Location: in between
Posts: 773
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Bluedaisy, I've been having recurrent UTI problems this pregnancy and I haven't noticed ANY symptoms.  I'm having a consult with a urologist this afternoon-- I'll pass along any general info I get.  Otherwise, I'd love to hear other peoples experiences with this as well. 


Partner to DH and mom to DD1 (3/2008) and DD2 (born 1/2012).
parsley is offline  
 

Tags
Pregnancy
User Tag List

Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off