signing me out after each visit? - Mothering Forums

Forum Jump: 
 
Thread Tools
#1 of 26 Old 12-30-2009, 06:28 PM - Thread Starter
 
goodheartedmama's Avatar
 
Join Date: Jan 2007
Location: Lexington, KY
Posts: 1,712
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It's not the end of the world, but I have it set up to remember me, and for the last few days, I have to sign in every time I visit. It's remembering my password for all other sites. Is anyone else having this problem?
goodheartedmama is offline  
Sponsored Links
Advertisement
 
#2 of 26 Old 12-30-2009, 08:22 PM
 
JessicaS's Avatar
 
Join Date: Nov 2001
Posts: 42,897
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
What browser are you using?

I would think that would have something to do with your cookie settings. You might take a look at that.

Not all those who wander are lost 
JessicaS is offline  
#3 of 26 Old 12-30-2009, 09:29 PM
 
Arianwen1174's Avatar
 
Join Date: May 2009
Location: I'm a (Willamette) Valley girl!
Posts: 843
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It's been doing that to me too and I haven't changed anything at all. I use Firefox and have been for several months. I thought it might be a glitch with my laptop but now I'm thinking it's not. Hmmmm...

Kali (pka Michelle) ~ crunchy wife to Cory (09/06) ~ Mama to H (03/90) & I (06/92)--bothnocirc.gifbf.jpg BF for 35 consecutive months ~ angel1.gif x 4

Arianwen1174 is offline  
#4 of 26 Old 12-30-2009, 11:11 PM
 
ellairiesmom's Avatar
 
Join Date: Mar 2008
Location: Back Where It All Began...Frankford Twp, NJ
Posts: 1,014
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Happening here too...just the past week or so. I did have to clear out my cookies recently but I re-clicked remember me so I thought I should be ok. I am running current Firefox on a MacBook.

Stephanie~hippie.gifwife to Dov, mama to Ella Irie (9/24/07) & Kaya Raine (2/1/10)~our vbac.gifbaby, born 45 hours after PROM!!!
ellairiesmom is offline  
#5 of 26 Old 12-30-2009, 11:13 PM
 
fruitfulmomma's Avatar
 
Join Date: Jun 2002
Location: Between the Rockies and a Flat Place
Posts: 4,197
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Me too but only on my side of the computer. It's fine on my husbands side. Both on firefox.
fruitfulmomma is online now  
#6 of 26 Old 12-30-2009, 11:28 PM
 
Kuba'sMama's Avatar
 
Join Date: Oct 2004
Location: Toronto, ON
Posts: 401
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ditto
Must be firefox i guess. Not only that, but it signs me out periodically, quite often actually. Have to keep signing in multiple times per session. Quite frustrating.

SAHM to one moody son J hat.gif(06-27-03), one super-girly daughter M hearts.gif (02-23-06) and welcome Sophie! energy.gif(05-23-10) expecting fourth in July baby.gif

Kuba'sMama is offline  
#7 of 26 Old 12-31-2009, 12:54 AM
 
ShadowMoon's Avatar
 
Join Date: Oct 2006
Location: Rhode Island
Posts: 1,390
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
This just started happening to me too, this week. I have Firefox (on a Mac) and I think it just recently updated. Maybe that's it?

S~ Peace loving, natural living, FuNkY vegan mama to Keiran bouncy.gif 23/Dec/06:
"Our lives begin to end the day we become silent about things that matter" ~~ MLK
ShadowMoon is offline  
#8 of 26 Old 12-31-2009, 11:07 AM
 
petey44's Avatar
 
Join Date: Nov 2008
Posts: 175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It's been doing it to me too off and on for about the past week, but I don't use Firefox, just Internet Explorer. It's also been happening on my blackberry. I'm pretty sure nothing's updated on my computer, and positive nothing's updated on my blackberry.
petey44 is offline  
#9 of 26 Old 12-31-2009, 11:24 AM - Thread Starter
 
goodheartedmama's Avatar
 
Join Date: Jan 2007
Location: Lexington, KY
Posts: 1,712
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I use firefox, too, and nothing has been changed. I visit other message boards and have not had this problem.

Glad to hear it's not just me! Mods, is someone going to look into this for us?
goodheartedmama is offline  
#10 of 26 Old 12-31-2009, 12:18 PM
 
fullofgrace's Avatar
 
Join Date: Nov 2002
Location: New England
Posts: 15,416
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I use Firefox on my Mac and have not had this problem. Well, my Firefox did get fussy about my needing to be logged in at both http://www.mothering.com/discussions -AND- http://mothering.com/discussions For some reason it treated both as separate sites and I'd appear logged in at one address and logged out at the other. Maybe try that?

Wife of 1. Mom of 3. Conquering disability challenges, one achievement at a time.
 

fullofgrace is offline  
#11 of 26 Old 12-31-2009, 04:32 PM
 
mountainsun's Avatar
 
Join Date: Jan 2005
Location: sw fl
Posts: 1,962
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Was just coming to ask anout this!

Using IE here and this has been happening for several days now? Have not changed any settings on my end.

  homeschooling, earth loving Mama to 3 crazy, wonderful boys, ages 10 & 7, & 3 mos.,3 spirit babies                                Inch by inch, row by row.  Gonna make this garden grow  
mountainsun is offline  
#12 of 26 Old 12-31-2009, 05:16 PM
 
Eman'smom's Avatar
 
Join Date: Mar 2002
Posts: 6,099
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It's happening for me too. On both computers with completely different software.

Mom to ds 9 dd 7 : and dd 3/08 : if I can I go to
Eman'smom is offline  
#13 of 26 Old 01-01-2010, 12:11 AM
Administrator
 
cynthia mosher's Avatar
 
Join Date: Aug 1999
Location: Arabia!
Posts: 38,744
Mentioned: 21 Post(s)
Tagged: 1 Thread(s)
Quoted: 112 Post(s)
Do any of you have Google Wave installed on your computer?

cynthia mosher is offline  
#14 of 26 Old 01-01-2010, 01:24 AM
 
Samm's Avatar
 
Join Date: Oct 2005
Posts: 217
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The same has been happening to me also. I'm also and IE user and do not have google wave installed.

Samm
Samm is offline  
#15 of 26 Old 01-01-2010, 02:48 AM
 
Arianwen1174's Avatar
 
Join Date: May 2009
Location: I'm a (Willamette) Valley girl!
Posts: 843
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Cynthia Mosher View Post
Do any of you have Google Wave installed on your computer?
Nope. I also tried both URLs that fullofgrace mentioned and I'm having the problem with both of them. Grrrrrr.

Kali (pka Michelle) ~ crunchy wife to Cory (09/06) ~ Mama to H (03/90) & I (06/92)--bothnocirc.gifbf.jpg BF for 35 consecutive months ~ angel1.gif x 4

Arianwen1174 is offline  
#16 of 26 Old 01-01-2010, 02:53 AM
Administrator
 
cynthia mosher's Avatar
 
Join Date: Aug 1999
Location: Arabia!
Posts: 38,744
Mentioned: 21 Post(s)
Tagged: 1 Thread(s)
Quoted: 112 Post(s)
The problem is related to a recent vBulletin security patch that I placed last week. Several other vBulletin communities are reporting the same problems for their members. One of vBulletin's developer's is looking into how it can be fixed. In the meantime I have increased the session timeout to 48 hours. Hopefully that will help most of you.

Others have reported that the issue resolves after a few days. So it may be that it will just stop happening. But I'll check in again with the vB developer and see if he came up with anything specific to resolve it.

cynthia mosher is offline  
#17 of 26 Old 01-01-2010, 03:07 AM
 
georgia's Avatar
 
Join Date: Jan 2003
Location: tl;dr
Posts: 25,384
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks, Cynthia!

I have retired from administration work, so if you have a question about anything MDC-related, please contact Cynthia Mosher. Thanks!
 
georgia is offline  
#18 of 26 Old 01-01-2010, 04:39 AM
 
JessicaS's Avatar
 
Join Date: Nov 2001
Posts: 42,897
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thank you Cynthia!!

Not all those who wander are lost 
JessicaS is offline  
#19 of 26 Old 01-01-2010, 10:52 AM
 
minxin's Avatar
 
Join Date: Mar 2003
Location: ithaca, ny
Posts: 72
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It's happening to me, too. Since Christmas day.

punk rock mom to Milo, my unschooling anarchist snuggle buddy :
minxin is offline  
#20 of 26 Old 01-01-2010, 06:22 PM
 
ShadowMoon's Avatar
 
Join Date: Oct 2006
Location: Rhode Island
Posts: 1,390
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks for looking into it!

S~ Peace loving, natural living, FuNkY vegan mama to Keiran bouncy.gif 23/Dec/06:
"Our lives begin to end the day we become silent about things that matter" ~~ MLK
ShadowMoon is offline  
#21 of 26 Old 01-01-2010, 06:32 PM
Administrator
 
cynthia mosher's Avatar
 
Join Date: Aug 1999
Location: Arabia!
Posts: 38,744
Mentioned: 21 Post(s)
Tagged: 1 Thread(s)
Quoted: 112 Post(s)
You're welcome! Has the change in the session timeout setting helped?

cynthia mosher is offline  
#22 of 26 Old 01-01-2010, 09:58 PM - Thread Starter
 
goodheartedmama's Avatar
 
Join Date: Jan 2007
Location: Lexington, KY
Posts: 1,712
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
No, it isn't helping. I appreciate the help, though, and hopefully it will be fixed soon enough!
goodheartedmama is offline  
#23 of 26 Old 01-02-2010, 12:25 AM
 
sunfish21's Avatar
 
Join Date: Jun 2009
Location: Wisconsin
Posts: 298
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
48 hours? I still can't make it more than a couple....and it isn't a huge deal. Just minorly irritating!

Single HB mama to 2!
sunfish21 is offline  
#24 of 26 Old 01-02-2010, 01:06 AM
Administrator
 
cynthia mosher's Avatar
 
Join Date: Aug 1999
Location: Arabia!
Posts: 38,744
Mentioned: 21 Post(s)
Tagged: 1 Thread(s)
Quoted: 112 Post(s)
Darn. I'll change the session timeout to a more reasonable time.

Let's give it the weekend and see if the problem has resolved itself on Monday. For those who want to try it, you can manually remove your mothering.com/www.mothering.com cookies and login again. Some have reported that to resolve it for them. Here's what the vB dev wrote:

Quote:
PL2 changes the main Cookie Salt - which invalidates everyones forum cookie, meaning they will be logged out when their session expires. When they login again they must check remember me to store the details again.

Anyone still having issues after that has a corrupt cookie, and should delete it (sorry, but how depends on your browser).
Quote:
I can reproduce the behavior exactly as described.
The behavior I'm looking at is:
1) User logs in, clicking remember me
2) Salt string changes (upgrading to PL2 causes this).
3) User is logged in
4) Session times out (or session cookie manually removed)
5) User is logged out, despite having clicked remember me.
6) User logs in again, clicks remember me.
7) User is logged in.
8) Session times out (or session cookie manually removed)
9) User is logged in.

I'm working with FF3.5.6 at the moment, which was one of the reported problem browsers. This is the expected behavior from the code.
I have read elsewhere that you should close all browser windows before removing cookies. For those who delete from their browser, close all browser windows/tabs except one and delete your mothering domain cookies. Then shut your browser down and restart it. Then you can log back in, being sure to click the "Remember Me" box and see if you stay logged in.

cynthia mosher is offline  
#25 of 26 Old 01-03-2010, 10:35 AM - Thread Starter
 
goodheartedmama's Avatar
 
Join Date: Jan 2007
Location: Lexington, KY
Posts: 1,712
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Clearing my cookies and restarting my computer seems to have resolved the issue. Thanks!
goodheartedmama is offline  
#26 of 26 Old 01-03-2010, 10:42 AM
Administrator
 
cynthia mosher's Avatar
 
Join Date: Aug 1999
Location: Arabia!
Posts: 38,744
Mentioned: 21 Post(s)
Tagged: 1 Thread(s)
Quoted: 112 Post(s)
Great! Thanks for letting us know.

cynthia mosher is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off