On and off spotting after giving birth. - Mothering Forums

Forum Jump: 
 
Thread Tools
#1 of 1 Old 08-10-2007, 02:31 AM - Thread Starter
 
mf_colon's Avatar
 
Join Date: Oct 2006
Location: Bronx, New York
Posts: 410
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi all!

I just wanted to get some input. I gave birth to DD 6 months ago, on my second month after birth I had some spotting which I thought was my period returning but after that it skipped a month, came back and then skipped. Last month in July, a had one full week of flow and I finally though that was my P returning but now I am in August and nothing (and no I am not pregnant.)

Is this normal? When do menses become normal again?

BTW, I am EB'ing on demand, we co-slept for a while and now she sleeps in the room with me and I am with her pretty much the whole day.
mf_colon is offline  
Reply

Quick Reply
Message:
Drag and Drop File Upload
Drag files here to attach!
Upload Progress: 0
Options

Register Now

In order to be able to post messages on the Mothering Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off