old pump died - Mothering Forums

Forum Jump: 
 
Thread Tools
#1 of 3 Old 03-14-2012, 07:31 PM - Thread Starter
 
purplerose's Avatar
 
Join Date: Dec 2010
Posts: 899
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

nak.

i had an evenflo single electric pump i had bought in 2002, i used it for that baby and then for this baby but it died recently. i don't know exactly which pump it was but the model # is 52130 and it may have had "deluxe" in the name. i bought a medela single deluxe but it hurts and i can't even let down for it. if anyone knows what evenflo pump it was and knows one comparable to it i'd appreciate knowing.


drowning in hormones with 4 daughters and an understanding, loving hubby. also some dogs. my life is crazy and we are always learning.

purplerose is offline  
Sponsored Links
Advertisement
 
#2 of 3 Old 03-15-2012, 11:27 AM
 
LilMomma83's Avatar
 
Join Date: Jan 2007
Posts: 2,630
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Does yours have the silicone insert (I just googles evenflo single electric, so forgive me if I am way off here)? Could you put that into your medela if it does? I know I have an Avent and it has a soft insert and that's the only way I can let down...the insert fits my medela though too so sometimes I use the medela instead so long as I put the insert in.

LilMomma83 is offline  
#3 of 3 Old 03-15-2012, 02:33 PM - Thread Starter
 
purplerose's Avatar
 
Join Date: Dec 2010
Posts: 899
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

thanks for the tip, i will try that and see if it helps.


drowning in hormones with 4 daughters and an understanding, loving hubby. also some dogs. my life is crazy and we are always learning.

purplerose is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off