First time mother baby not engage early - Mothering Forums

Forum Jump: 
 
Thread Tools
Old 10-19-2006, 05:38 PM - Thread Starter
 
dex_millie's Avatar
 
Join Date: Oct 2006
Location: MD
Posts: 1,604
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I hope people still visit this forum, seems like everyone is having their baby(I always use to visit this site, but had problems registering so I just use to browse). I have a question - Is there any first time mothers that their babies didn't engage early. My due date was Oct. 16 (no baby yet though), but my baby still hasn't engage in my pelvis. And if your baby didn't engage how long before you went into labor?
dex_millie is offline  
Sponsored Links
Advertisement
 
Old 10-19-2006, 06:04 PM
 
ruthieroo's Avatar
 
Join Date: Aug 2005
Posts: 160
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi there! I have lurked mainly as well and, yes, it seems like hardly anyone is pregnant anymore but we're out here! (I'm still pregnant!)

My first son didn't engage early. I don't know when he did but I know he had NOT engaged and still quite high up at 38 weeks and yet he was born at 38 weeks and several days. This baby, on the other hand, I think dropped at 36 weeks--my bladder is squished...read: peeing constantly!...and I have pressure down there. This is something I never experienced with my son until the night before I went into labor. And I'm almost 39 weeks and no baby. So it's always different, I guess! But yes, don't fear: labor can still happen suddenly (totally took me by surprise last time) and progress smoothly without baby dropping early.
ruthieroo is offline  
Old 10-19-2006, 07:06 PM
 
ladybugchild77's Avatar
 
Join Date: Jun 2004
Location: Phoenix, AZ
Posts: 2,420
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Not too much time to post - toddler is covering her high chair in marker. I did not "drop" until labor. Kiera's head did not actually engage fully until late labor (transition). I felt this wierd pop where she dropped like 3 stations and then I HAD to push...HTH!
ladybugchild77 is offline  
 
User Tag List

Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off