GRACO Snugride 30 Install Problem - Mothering Forums

Forum Jump: 
 
Thread Tools
Old 06-19-2012, 09:32 AM - Thread Starter
 
sraplayas's Avatar
 
Join Date: Mar 2005
Location: land of tomorrow
Posts: 1,312
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

So we are waiting for #3 and have had the infant seat in for a few weeks.

 

We have a Mit. Montero with the seat latches (next to the buckles). We followed the instructions in the manual and still cannot get a good tight fit. It just seems like something is missing.

 

The manual says to test it by trying to move it side-to-side and up-and-down. When I do that, it moves more than an inch, esp. side-to-side. DH is strong, and he installed it. So what are we missing here?

 

Thanks for the input. :)


SAHM bf.gif, DH reading.gif, DD  (03/05) dust.gif, DS1hola.gif(01/09), DS2 babyf.gif(06/12) & dog2.gif

sraplayas is offline  
Sponsored Links
Advertisement
 
Old 06-20-2012, 09:58 PM
 
ashleyhaugh's Avatar
 
Join Date: Jun 2005
Location: San Antonio, TX
Posts: 4,315
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Are you testing it at the belt path? That's where you need to check, the top is gonna move every which way

*~*Ashley*~* newly single mama to Tristan 10/01/2007
ashleyhaugh is offline  
 
User Tag List

Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off