Vaginal pain/pressure already? - Mothering Forums

Forum Jump: 
 
Thread Tools
#1 of 4 Old 10-25-2010, 10:11 AM - Thread Starter
 
gagirl2008's Avatar
 
Join Date: Jun 2008
Posts: 202
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi ladies,

I'll be 16 weeks tomorrow but I'm having horrible pain and pressure. When I went at 8 weeks they said I had bacteria in my urine and gave me an antibiotic but I didn't take it because I didn't have symptoms. Then when I went back at 12 weeks they said the same thing and I said I would take it but never started it. I finished the antibiotic yesterday but I don't think it helped. I hope my urine doesn't show anything on the 27th when I go back. My midwife said that was probably why I was hurting.

Is anyone else hurting like this?

Thanks!
gagirl2008 is offline  
#2 of 4 Old 10-25-2010, 11:01 AM
 
Liora's Avatar
 
Join Date: Aug 2010
Posts: 294
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I think round ligament pain can hurt in the vaginal area sometimes. And, in general, I feel swollen and sensitive down there during pregnancy due to all the increased blood flow. I wouldn't call it "pressure" though. or horrible. When in doubt I'd call your MW.

Liora - wife to Pete, IVF miracle DD babygirl.gif (2.11.09) 11 year Infertility survivor! FET miracle TWIN boys babyboy.gifbabyboy.gifborn 2/28 at 32 weeks and growing strong in the NICU.
Liora is offline  
#3 of 4 Old 10-25-2010, 04:34 PM
 
EricaRN's Avatar
 
Join Date: Jan 2010
Location: Indiana
Posts: 336
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by gagirl2008 View Post
Hi ladies,

I'll be 16 weeks tomorrow but I'm having horrible pain and pressure. When I went at 8 weeks they said I had bacteria in my urine and gave me an antibiotic but I didn't take it because I didn't have symptoms. Then when I went back at 12 weeks they said the same thing and I said I would take it but never started it. I finished the antibiotic yesterday but I don't think it helped. I hope my urine doesn't show anything on the 27th when I go back. My midwife said that was probably why I was hurting.

Is anyone else hurting like this?

Thanks!
I would definitely keep an eye on it. This is what happened to me with my son. Found bacteria in my urine at 8 weeks and it continually got worse. I did take one 10 day round of antibiotics but it didn't help. My water broke at 35 weeks because the infection was running so rampant. It also meant my son had to stay in the NICU for a week because of the infection in his body that he was trying to fight off. My infection was Group B Strep but there are plenty of other forms of bacteria that can cause it. My Drs didn't take it seriously because they said they would just give me IV antibiotics during labor but the infection was too out of control and caused my water to break early. Anyway, if you're bothered by it or notice an increase in discharge, especially if it is yellow at all, I would call your MW and tell them you're concerned. I trusted my Drs that everything would be fine on its own and it wasn't. I would hate to see that happen to anyone else. If treated it's not a huge deal, but if it gets left alone it can obviously cause major problems. Good luck and keep us posted on how things go!

Wife to John, Mom to Melanie (1/08), Deklan (5/09) and stork-suprise.gif due April 11, 2011 h20homebirth.gif vbac.gif & just started cd.gif
EricaRN is offline  
#4 of 4 Old 10-26-2010, 09:37 PM
 
StarCat's Avatar
 
Join Date: Mar 2005
Location: Florida
Posts: 1,441
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ummmm...me! Not UTI related at all- I think I have a varicose vein or something in the vajayjay. well, not in but near... (is this tmi??) after 12 hours of busting my butt at work I definitely have some pressure/discomfort down below. eeeek. this is gonna get worse before it gets better isn't it??

Beccalove.gif mama to 2 girls and  IT'S A BOY!! 3/31/11 babyboy.gif
StarCat is offline  
Reply

Quick Reply
Message:
Drag and Drop File Upload
Drag files here to attach!
Upload Progress: 0
Options

Register Now

In order to be able to post messages on the Mothering Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off