Why is my body stuck in "trying to ovulate" mode?! (Chart link FIXED!) - Mothering Forums

Forum Jump: 
 
Thread Tools
#1 of 5 Old 07-14-2010, 10:19 AM - Thread Starter
 
Carolyn R's Avatar
 
Join Date: Mar 2008
Posts: 444
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
So this is getting crazy. So for almost 3 weeks mid-cycle, I have had TONS of EWCM, ovulation cramping like crazy, even some spotting which I assumed was from ovulating. But no temp rise to indicate O, and I keep feeling "O-ish"...as in increased sex drive, sore bbs, etc.

If you look at my chart http://www.fertilityfriend.com/home/2b86cb I thought way back on cd 19 that I had O'd, but then obviously not.

I've always had longish cycles, but they're generally pretty predictable. I've always O'd somewhere around day 19-23, and lp is consistently around 13 days. This one has thrown me off, and makes me wonder if something is wrong.

Any feedback, opinions? Thanks!

SAHM to Abraham (9) Gillian (5) Adrienne (3) and baby boy coming in October! 

Always missing our Gianna, lost during fullterm labor (8/23/04)
Sticking together through the good and the bad with dh of 10 yrs!

Carolyn R is offline  
Sponsored Links
Advertisement
 
#2 of 5 Old 07-14-2010, 02:23 PM
 
Kinza's Avatar
 
Join Date: Feb 2010
Posts: 347
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Your chart link is taking me to my own fertility friend chart. If you go to your home page (Sharing --> homepage setup) you'll see at the top something like "Your charting homepage" and an address that ends with 6 numbers and letters.

A and M, June 2012
Kinza is offline  
#3 of 5 Old 07-15-2010, 12:15 AM - Thread Starter
 
Carolyn R's Avatar
 
Join Date: Mar 2008
Posts: 444
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks, Kinza, for the heads up! The link should be working now!

SAHM to Abraham (9) Gillian (5) Adrienne (3) and baby boy coming in October! 

Always missing our Gianna, lost during fullterm labor (8/23/04)
Sticking together through the good and the bad with dh of 10 yrs!

Carolyn R is offline  
#4 of 5 Old 07-15-2010, 01:45 PM
 
Kinza's Avatar
 
Join Date: Feb 2010
Posts: 347
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Well, I'm not an expert, but I don't think your chart shows an O yet. Today's temp is higher than any others, so it's possible you O'd on cycle day 31 (yesterday, 7/14). See if your temp stays up the next two days, is the only thing I can think of.

I know sometimes I gear up to O and stay in that mode for weeks before I actually do O. So, I wouldn't be terribly worried over one wild cycle. I think it happens to everyone occasionally. You'll eventually pop an eggie out, or else you'll have an anovulatory cycle, which happens to all of us occasionally.

A and M, June 2012
Kinza is offline  
#5 of 5 Old 07-16-2010, 01:39 PM
 
KaliShanti's Avatar
 
Join Date: Mar 2008
Location: Lindale,TX
Posts: 2,284
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sorry, no O yet. *hug* I know how it is to have cycles like this.

Jesus-loving Doula/Birth Photographer Mama to Tor 4/2007, Zion 11/2009, Enoch 11/2011, and Zephyr due 12/13/2013

KaliShanti is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off