slow rising hormones question - Mothering Forums

Forum Jump: 
 
Thread Tools
#1 of 1 Old 01-05-2008, 04:23 AM - Thread Starter
 
Shy0717's Avatar
 
Join Date: Jun 2005
Location: Dallas, TX
Posts: 586
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quick intro....I'm Shy (24) expecting my first little one 8/24/08. My lmp that I have recorded was 11/18/07. I had sex on 12/1/07 and 12/2/07. I got a positive pregnancy test on 12/14/07. I went to the ER for some spotting on 1/1/08 and had my beta levels drawn, it was 2409. Exactly 48 hrs on 1/3/08 I had them re-drawn and it was 3140 ish (I was panicking a little but I remember thinking it only rose 600). I'm currently 6 weeks and 5 days. Has anyone had this happen to them and everything been ok?? I also had an u/s when I went to the ER on the 1st and all they saw was what looked to be a possible gestational sac, no heartbeat or anything yet. I go back Monday for more labs and Thursday for an u/s. I also talked them into giving me progesterone over the weekend since my progesterone levels weren't back yet. Anyone experienced this before?? I'm just a little worried. Thanks ladies.

 dreads.gif  ribbonyellow.gif Proud Army Wife to DH ribbonyellow.gif  mama to one busy boy blahblah.gif and his dog2.gif  
Shy0717 is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off