Mothering Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter · #1 ·
<p>So yesterday was 3 weeks from the day we lost our precious Molly. I was only 5 weeks pregnant, but feel in my heart that i carried a girl. Plus, naming her really  helped on the long road to healing. I resumed temp'ing 3 days after the loss. I believe my body & temps were basically back to normal by day 7 or 8. But my temps have been SUPER weird since, nothing like a usual pattern. I had O pains & thought i possibly could have ovulated day 9, but there is no temp climb after that.  There's a weird steady climb days 12-14, then yesterday it dropped low again & was the same this morning. Any mamma's who've been through loss wanna peek at my chart & share an opinion?  <a href="http://www.fertilityfriend.com/home31b61f" target="_blank">http://www.fertilityfriend.com/home31b61f</a></p>
 

·
Registered
Joined
·
340 Posts
<p>For some reason your chart link isn't working for me. I don't know what your cycles are normally like, and I've also heard it's different for every body and every loss, you just never know. Sometimes it seems like so many people O right away, on schedule and their bodies jump right back on board. Personally mine hasn't been that way. With my 5.5 week loss, I didn't O until CD31 and then my LP temps were rather ragged. But I also tend to be a late O-er anyway (like CD 18-25) and have been known to have lots of false starts and saw toothed charts. So that wasn't so off the wall for me, kwim?</p>
<p> </p>
<p>It can just take a while for your body to really get back on track even with an early loss. Sounds like maybe you're seeing some "false starts" as your hormones try to get back in tune? Are you charting CF and/or CP too? I know it's so frustrating especially if you're wanting to get to TTC again. So sorry for your loss, mama. Hope your body cooperates with you soon.</p>
 

·
Registered
Joined
·
107 Posts
Discussion Starter · #3 ·
<p><a href="http://www.fertilityfriend.com/home/31b61f" target="_blank">http://www.fertilityfriend.com/home/31b61f</a></p>
<p> </p>
<p>maybe it'll work this time. i do chart CM but not CP. i was kinda thinking maybe i'd had a few false O starts too, maybe my body was trying to gear up but couldn't make it all the way. i've had O pains, idk. i'd hoped to be one of those people who O'd right after the loss, i finished passing everything & spotting & bleeding pretty quick afterwards i think.</p>
 

·
Registered
Joined
·
340 Posts
<p>Yeah that's sure what it looks like to me - false starts, body gearing up to O but not quite getting there yet. Good sign it's trying though, right?! It's happened to me a lot. It is very frustrating and adds a whole extra stress to TTC, the up and down for weeks. <span><img alt="irked.gif" src="http://files.mothering.com/images/smilies/irked.gif"></span> I hope it straightens out for you soon!</p>
<br>
 
1 - 4 of 4 Posts
Top