Mothering Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
340 Posts
Discussion Starter #1
<p>I finally started bleeding yesterday at 10 weeks, 3 weeks after fetal demise. For about 2 hours last night, I had contractions 2-3 min apart and moderate bleeding. After I passed a couple of half dollar to plum sized clots, it pretty much just stopped. Cramps faded, bleeding tapered right off. Now this morning I'm barely spotting a bit of old looking blood. My BBT was up and I'm warm but not feverish. Feel pretty ok.</p>
<p> </p>
<p>So is it even possible that that was "it"? Could I have reabsorbed a lot while waiting? Has anyone ever had a late 1st tri loss that was so light and quick? This was not that different from my 5.5 week loss! I feel like I've read lots of stories on here of mamas thinking they were done and then a day or several later having a whole other (worse) round of it to really complete....What can I do to make sure I've completed, and what should I be watching out for besides the obvious infection signs?</p>
<p> </p>
<p>I've got to go in to my OB at some point today anyway for Rhogam and blood draw, but she's not very helpful and we don't have a good relationship. I trust you mamas more!</p>
 

·
Registered
Joined
·
3,364 Posts
<p>my insurance covers it so I always go for a followup u/s to make sure my uterus is clear. It eases my mind. Since most likely you absorbed everything I would recommend the u/s just to make sure. I am glad the physical part is well on its way to being over for you i know the waiting has been challenging.</p>
 

·
Registered
Joined
·
1,451 Posts
<p>Sounds a lot like my first m/c with blighted ovum at 12wks. I didn't get checked; everything was fine and I conceived the next cycle.</p>
 
1 - 3 of 3 Posts
Top