Mothering Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
418 Posts
Discussion Starter · #1 ·
I am (was) pretty sure I ovulated between cd15-17 based on cervical mucus, ovulation pain, and an positive opk on cd 12 (I didn't note all of it at the time though). I get pretty strong ovulation pain,followed by a few days of cramping aftewards, so it's usually a sure thing if I have those symptoms. I also have certain post-o digestive symptoms. Also, I didn't start temping until CD10 (and I used soy, cd3-7)<br><br>
But my fertility friend is not detecting anything,and I am confused. Take a look?<br><br><a href="http://www.fertilityfriend.com/home/19b8de" target="_blank">http://www.fertilityfriend.com/home/19b8de</a><br><br>
Thanks
 

·
Registered
Joined
·
1,900 Posts
Maybe not enough temps to give an accurate coverline? But those temps are awfully low to be post O? I'd say cd 20 will get crosshairs if you get a couple more temps in that range. You could have ahd a pos OPK and geared up to O but didn't, and now what you perceive as creamy CM was the body revving up again? Unfortunately only time will tell. Good luck!
 

·
Registered
Joined
·
418 Posts
Discussion Starter · #3 ·
I went back in and entered additonal information from this past week and last week and now it's giving me crosshairs for the 15th (dashed line). I looked looked at an older cycle in 2007 where I got pregnant, and I had to override it then and put in my ovulation day because Fertility Friend never detected ovulation from temps.<br><br>
I think I might have a slighter temp shift than others, as well as being sensitive to outside temperature changes.
 
1 - 3 of 3 Posts
Top