Mothering Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3,992 Posts
Discussion Starter #1
With DD1 I lost mucus plug and had bloody show all at once, then went into labor the next morning. With DD2 I had the same thing the day before my water broke....bloody show+mucus.<br><br>
Over the last 3-4 days I have lost a few hefty chunks of mucus but no bloody show. I imagine that even with no bloody show, the substantial loss of mucus plug means Something is going on (even if labor isn't imminent), no?<br><br>
Anyone else losing lots of mucus but no bloody show?
 

·
Registered
Joined
·
2,564 Posts
My mucus plug showed up with bloody show like what you are used to.<br><br>
However, my best mommy's friend mucus plug popped out a week before she had a baby <img alt="" class="inlineimg" src="http://www.mothering.com/discussions/images/smilies/smile.gif" style="border:0px solid;" title="smile"> It's your countdown!
 

·
Registered
Joined
·
1,363 Posts
i started losing mine yesterday. 2 huge amounts then it subsided a bit and i was getting smaller pieces. then this morning another huge amount. how much is in there? <img alt="" class="inlineimg" src="http://www.mothering.com/discussions/images/smilies/lol.gif" style="border:0px solid;" title="lol"> mine is just yellow, no bloody show yet.
 

·
Registered
Joined
·
2,564 Posts
The first time my mommy friends told me about the mucus plug (years before I got pregnant with DD) I thought they were JOKING! It seemed so gross to me. Now I love talking about them!
 

·
Registered
Joined
·
2,087 Posts
i have never lost my plug until labor was imminent and it has always been either along with or followed very shortly by bloody show. however, i have several friends who have lost plug for up to 2 weeks before labor. i think it's bloody show that is the true indicator, not the plug, because the plug can regenerate.
 

·
Registered
Joined
·
1,203 Posts
I don't remember anything with mine with DD, but with DS it came out while I was in active labor.<br>
Still zilch here.
 

·
Registered
Joined
·
163 Posts
I never saw any mucus or bloody show with my previous pregnancies, but I lost a bunch of mucus on Thursday, all day long, and some more on Friday. But since then, NOTHING. ugh!<br><br>
I wish labor would just start already, because I'm facing an induction soon for high BP if I can't get going on my own.
 

·
Registered
Joined
·
338 Posts
Lots of mucus here too, but no bloody show and no labor. <img alt="" class="inlineimg" src="http://www.mothering.com/discussions/images/smilies/greensad.gif" style="border:0px solid;" title="greensad"><br><br>
With 4 out of my 6 (all the boys) I lost my mucus and had bloody show once I was well into labor. With my other 2 (the girls) I lost my plug between 3 days and a week before labor kicked in, with no bloody show until labor was well under way. This baby is a girl, and I lost a lot of yellow, stringy mucus last Wednesday ad was hoping for a Mother's Day baby if things followed my previous track record. NADA. ZIPPO. NOTHING. <img alt="" class="inlineimg" src="http://www.mothering.com/discussions/images/smilies/greensad.gif" style="border:0px solid;" title="greensad"> Some days I have had a lot of mucus and other days there is nothing at all. Just goes to show you every pregnancy is different. I do agree with what someone else said about bloody show seeming to be more of a true indicator of imminent labor than the mucus plug. Ive had clients that have lost plug and waited 3weeks for a babe to arrive.
 

·
Registered
Joined
·
660 Posts
Yesterday and today I've lost quite a bit of mucus too... no bloody show though. On Tuesday at my appointment I was effaced 80% and not dilated at all. Who knows what's going on. I so wish that losing the mucus plug meant labor is going to be underway soon! I am ready to meet this girl!
 
1 - 9 of 9 Posts
Top