Mothering Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
<p>Hi, Mammas!</p>
<p> </p>
<p>I am at work and my Medela Pump in Style seems to have lost some suction.  I peeled off the face plate and am looking at the diaphragm.  I have no idea how it should or should not look.  When I turn the pump on, the diaphragm seems crooked.  It has more movement on the right-hand side than the left.  Is this normal?  Or should I be replacing something?  If it's not normal, do I need to just replace the diaphragm?</p>
<p> </p>
<p>Thanks for your help!</p>
<p> </p>
<p>Carrie</p>
 

·
Registered
Joined
·
4,342 Posts
<p>The little white flap things that snap on to the yellow part...you should try replacing those.  I know it's hard to believe, but I always see a major suction increase when I replace them.  You could also check your tubing, but I think you'll find replacing those white membrane thingys will make a difference.</p>
 

·
Registered
Joined
·
1 Posts
<p>Carrie - I have the same thing happening to my pump - could you post an update if you figured out what the issue was with your pump?  I'm using a pump that a friend gave me.  I started using it more regularly in the past 5 months.  Although Koalamommy's suggestion to change the membrane is nice, I know it's not the flange part that's causing the issue and that I'm having the same thing happen.  I took off the front panel and turned on to see the diaphragm moving in a crooked way.  I was renting a symphony and am thinking of renting again since my supply has gone down.  ALthough that might not be a pump issue but just an older baby issue.  (I have twins who are now 10 months).</p>
 
1 - 3 of 3 Posts
Top