Mothering Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1,900 Posts
Discussion Starter · #1 ·
I've been EPing for my twins since January, 2006. I'm slowly weaning down my pumps per day, and have settled at 3 for a while, which has been going just fine. Suddenly the past 2-3 days my nipples are really sore and painful. Not like skin irritated from the pump painful - just sore in general, KWIM? I haven't had this happen before. I don't see any way I could possibly be pregnant, before you go there (I obviously already did). Though I might actually consider POAS just to shut my own crazy self up, the chances are infinitessimal. I probably ovulated sometime in the past few days, but I haven't had that bother me in the past few months since I started getting periods again. Any thoughts?
 

·
Registered
Joined
·
43,705 Posts
Just because you've been getting periods for a few months doesn't mean you've been ovulating all this time. This might have been your first ovulation postpartum, or some other weird hormonal thingie.

It could also be thrush or a bacterial infection- in the early stages.
 

·
Registered
Joined
·
1,900 Posts
Discussion Starter · #4 ·
It doesn't really feel like an infection - I have BTDT. They just feel soooooo sensitive.

I'm pretty sure I have been ovulating since I got my first PP period in November. Basing this on EWCM and...well...the return of desire!
Could be wrong, of course, and I haven't been charting (to avoid! to avoid!)

I also noticed a serious uptick in my supply yesterday. I wonder if the two are related.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top